Unterschiede zwischen den Revisionen 1 und 3 (über 2 Versionen hinweg)
Revision 1 vom 2010-08-18 18:15:07
Größe: 1539
Autor: BodoBellut
Kommentar:
Revision 3 vom 2010-09-12 17:58:16
Größe: 5064
Autor: BodoBellut
Kommentar:
Gelöschter Text ist auf diese Art markiert. Hinzugefügter Text ist auf diese Art markiert.
Zeile 6: Zeile 6:

|| '''Prefix''' || '''2002:5361:2AF9:9700::0/48''' ||
|| PING Servernetz 1 || 2002:5361:2AF9:9742::0/64 ||
|| Membersnetz || 2002:5361:2AF9:9741::0/64 ||
|| Prima Servernetz || 2002:5361:2AF9:9748::0/64 ||
Zeile 29: Zeile 34:
interface FastEthernet0/1.10
 description PING Servernetz 1
 encapsulation dot1Q 10
 ip address 83.97.42.1 255.255.255.192
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip ospf authentication
 ip ospf authentication-key 7 070E324F4B071D55
 ip ospf priority 254
 ipv6 address 2002:5361:2AF9:9742::1/64
 ipv6 enable
 ipv6 nd ra suppress
 ipv6 ospf 3 area 0.0.0.6
 no cdp enable
interface FastEthernet0/1.10
 description PING Servernetz 1
 encapsulation dot1Q 10
 ip address 83.97.42.1 255.255.255.192
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip ospf authentication
 ip ospf authentication-key 7 070E324F4B071D55
 ip ospf priority 254
 ipv6 address 2002:5361:2AF9:9742::1/64
 ipv6 enable
 ipv6 nd ra suppress
 ipv6 ospf 3 area 0.0.0.6
 no cdp enable
Zeile 46: Zeile 51:
interface FastEthernet0/1.40
 description Membersnetz
 encapsulation dot1Q 40
 ip address 83.97.41.1 255.255.255.192
 ip nat outside
 ip virtual-reassembly
 ipv6 address 2002:5361:2AF9:9741::1/64
 ipv6 enable
 ipv6 nd ra suppress
interface FastEthernet0/1.40
 description Membersnetz
 encapsulation dot1Q 40
 ip address 83.97.41.1 255.255.255.192
 ip nat outside
 ip virtual-reassembly
 ipv6 address 2002:5361:2AF9:9741::1/64
 ipv6 enable
 ipv6 nd ra suppress

interface FastEthernet0/1.50
 description Prima Servernetz
 encapsulation dot1Q 50
 ip address 83.97.48.30 255.255.255.192
 no ip redirects
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 ip ospf authentication
 ip ospf authentication-key 7 0014010F095A
 ip ospf priority 254
 ipv6 address 2002:5361:2AF9:9748::1/64
 ipv6 enable
 ipv6 nd ra suppress
 ipv6 ospf 3 area 0.0.0.7
 no cdp enable
Zeile 60: Zeile 82:
}}}

{{{
Zeile 70: Zeile 95:
'''vping'''

{{{
iface eth0 inet6 static
 address 2002:5361:2AF9:9741::6
 netmask 64
 gateway 2002:5361:2AF9:9741::1
}}}

'''griff'''

{{{
iface eth0 inet6 static
 address 2002:5361:2AF9:9748::10
 netmask 64
 gateway 2002:5361:2AF9:9748::1
}}}
Zeile 71: Zeile 114:

'''garfield (griff)'''

{{{
$ cat /etc/vservers/garfield/interfaces/1/ip
2002:5361:2af9:9748::5142

$ cat /etc/vservers/garfield/interfaces/1/prefix
64
}}}

'''europe2 (vping)'''

{{{
$ cat /etc/vservers/europa2/interfaces/1/ip
2002:5361:2AF9:9741::16

$ cat /etc/vservers/europa2/interfaces/1/prefix
64
}}}

Dokumentation der IPv6-Konfiguration bei PING

/!\ Work in progress. /!\

Bis zur Konfiguration der nativen IPv6-Adressen verwenden wir einen 6to4-Tunnel.

Prefix

2002:5361:2AF9:9700::0/48

PING Servernetz 1

2002:5361:2AF9:9742::0/64

Membersnetz

2002:5361:2AF9:9741::0/64

Prima Servernetz

2002:5361:2AF9:9748::0/64

Cisco

interface Loopback2002
 description 6to4 gw ipv4 interface
 ip address 83.97.42.249 255.255.255.255
 no ip redirects
 no ip proxy-arp
 no ip mroute-cache

interface Tunnel2002
 description 6to4 tunnel device
 no ip address
 no ip redirects
 ipv6 address 2002:5361:2AF9::1/128
 ipv6 traffic-filter ACL_v6_WAN_in in
 ipv6 mtu 1280
 tunnel source 83.97.42.249
 tunnel mode ipv6ip 6to4

interface FastEthernet0/1.10                                                    
 description PING Servernetz 1                                                  
 encapsulation dot1Q 10                                                         
 ip address 83.97.42.1 255.255.255.192                                          
 no ip redirects                                                                
 no ip proxy-arp                                                                
 ip nat outside                                                                 
 ip virtual-reassembly                                                          
 ip ospf authentication                                                         
 ip ospf authentication-key 7 070E324F4B071D55                                  
 ip ospf priority 254                                                           
 ipv6 address 2002:5361:2AF9:9742::1/64                                         
 ipv6 enable                                                                    
 ipv6 nd ra suppress                                                            
 ipv6 ospf 3 area 0.0.0.6                                                       
 no cdp enable                                                                  

interface FastEthernet0/1.40                                                    
 description Membersnetz                                                        
 encapsulation dot1Q 40                                                         
 ip address 83.97.41.1 255.255.255.192                                          
 ip nat outside                                                                 
 ip virtual-reassembly                                                          
 ipv6 address 2002:5361:2AF9:9741::1/64                                         
 ipv6 enable                                                                    
 ipv6 nd ra suppress                                                            

interface FastEthernet0/1.50                                                    
 description Prima Servernetz                                                   
 encapsulation dot1Q 50                                                         
 ip address 83.97.48.30 255.255.255.192                                         
 no ip redirects                                                                
 no ip proxy-arp                                                                
 ip nat outside                                                                 
 ip virtual-reassembly                                                          
 ip ospf authentication                                                         
 ip ospf authentication-key 7 0014010F095A                                      
 ip ospf priority 254                                                           
 ipv6 address 2002:5361:2AF9:9748::1/64                                         
 ipv6 enable                                                                    
 ipv6 nd ra suppress                                                            
 ipv6 ospf 3 area 0.0.0.7                                                       
 no cdp enable                                                                  

ipv6 route 2002::/16 Tunnel2002
ipv6 route ::/0 2002:C058:6301::1

ipv6 router ospf 3
 router-id 83.97.42.193
 log-adjacency-changes detail
 default-information originate always
 redistribute connected
 redistribute static

Server

vping

iface eth0 inet6 static
        address 2002:5361:2AF9:9741::6
        netmask 64
        gateway 2002:5361:2AF9:9741::1

griff

iface eth0 inet6 static
 address 2002:5361:2AF9:9748::10
 netmask 64
 gateway 2002:5361:2AF9:9748::1

VServer

garfield (griff)

$ cat /etc/vservers/garfield/interfaces/1/ip 
2002:5361:2af9:9748::5142

$ cat /etc/vservers/garfield/interfaces/1/prefix 
64

europe2 (vping)

$ cat /etc/vservers/europa2/interfaces/1/ip 
2002:5361:2AF9:9741::16

$ cat /etc/vservers/europa2/interfaces/1/prefix 
64

Software/IPv6 (zuletzt geändert am 2012-07-08 11:27:05 durch BodoBellut)